WordGlue 2.1

WordGlue 2.1 is supported on all Windows versions since Windows XP. It requires .NET 4.0 or later.

This download is an evaluation copy. It is fully featured but will expire after 30 days. See our purchase page for details of current special offers.

WordGlue .NET 2.1

For 32-bit or 64-bit versions of Windows


Release Date: 9 September 2016