ImageGlue is Postscript compatible which means that it can be used to render Postscript and related file formats such as EPS (Encapsulated Postscript) and PDF (Portable Document Format).

PostScript related formats are unusual in that they contain a set of drawing instructions rather than an array of colored pixels. These drawing instructions are often highly specific describing actual amounts of ink to be placed by a particular type of printer onto a particular type of paper. These factors mean that rendering this type of format for display on a computer monitor may require that you use image properties like resolution and color space.

ImageGlue handles raw Postscript which conforms to the Postscript Language Document Structuring Conventions Specification (see Adobe Technical Note #5001 for details). This is necessary because Postscript which does not conform to this standard lacks important information such as image size and Postscript version identifiers.

Postscript is a programming language with a sophisticated set of commands. As such a Postscript file is a program which must be run in order to produce a rendered output. In its rawest form a Postscript program may have full access to the local file system and it is entirely possible to write malicious Postscript applications.

To prevent damage caused by malicious Postscript programs there are a number of levels of security in place. Your first level of security is the fact that Postscript program is run inside a sandbox which allows read-only access to the file system. The second level of security is determined by the security settings you configure for IIS. This means that you should ensure that your IIS security settings are sufficient to prevent unauthorized access to any sensitive resources.